Linux Mint – problem with apt-get


I’m using linux mint, and while executing apt-get install <some-package> i encounter some errors. The errors from install are:

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/list/packages.medibuntu.org_dists_quantal_free_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

I run apt-get update and got a few errors. Here is the contents of the file error generated by the command apt-get update 2> error:

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/Release.gpg  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/free/i18n/Translation-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/free/i18n/Translation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/non-free/i18n/Translation-en_US  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/non-free/i18n/Translation-en  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/free/binary-i386/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/quantal/non-free/binary-i386/Packages  Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Any idea on how to fix this errors? (bonus – what caused them?)

One Response to “Linux Mint – problem with apt-get”

  1. Braiam says:

    Medibuntu project is not functional anymore, the packages were already merged with the main repositories packages, dropped because too old/buggy or were deemed otherwise unnecessary. There is no way to fix. Just remove the repositories from your source.list, so you don’t get a warning about “Failed to fetch”.

    enter image description here

    The Medibuntu repository has been unmaintained for several months, and has become more and more useless over the years. The project is now considered abandoned, and we recommend to disable the repository if you are using it.

    See http://gauvain.pocentek.net/node/61 and http://blogs.kde.org/2013/09/11/medibuntu-disappear-libdvdcss-now-direct-videolan for details.

    Thanks to all the Medibuntu users and contributors.

    https://launchpad.net/medibuntu/+announcement/11951

Leave a Reply

Question and Answer is proudly powered by WordPress.
Theme "The Fundamentals of Graphic Design" by Arjuna
Icons by FamFamFam