unmet dependencies for gir1.2-accountsservice-1.0 on Ubuntu 14.04.2


I’m trying to install a software package which depends on gir1.2-accountsservice-1.0. However, when I attempt to install gir1.2-accountsservice-1.0 I get the following message:

sudo apt-get install gir1.2-accountsservice-1.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gir1.2-accountsservice-1.0 : Depends: libaccountsservice0 (>= 0.6.35-0ubuntu7.2) but 0.6.35-0ubuntu7.1+SCSp3 is to be installed
E: Unable to correct problems, you have held broken packages.

OS: Ubuntu 14.04.2 LTS with Unity desktop

I tried getting it from here: https://launchpad.net/ubuntu/+source….35-0ubuntu7.2
but when I try to build this package I get a rather excessive list of dependency issues, so I would much rather install this through an apt-get install command.

What is the systemd equvalent to sysvinit 'X-Start-Before'?


Quoted from https://wiki.debian.org/LSBInitScripts.

X-Start-Before: boot_facility_1 [boot_facility_2...]

X-Stop-After: boot_facility_1 [boot_facility_2...]

provide reverse dependencies, that appear as if the listed facilities had should-start and should-stop on the package with these headers.

What is the systemd equvalent to sysvinit X-Start-Before?

Similar to systemd’s Before=, but stronger, as a dependency.

About Dependencies


In the absence of internet connection for the present, I am trying to use apt-offline. When I execute the order in terminal I get “ERROR: FATAL: Something is wrong with the apt system.” I have been told that this problem is probably a dependencies problem.

So I run “apt-get -f install” and there appeared some dependencies. I tried to install some of them to be, then, able to use apt-offline.

But, the problem is, it seems even more dependencies appeared. To the question then:

Question: Is there a way to “kill” all those dependencies? To somehow maybe get reed of them and be able to use the apt-offline?

Thank you.

NOTE: These are the orders:

1)

kwstas@debian:~$ su -c  'apt-offline set /tmp/apt-offline.sig'
Password: 

Generating database of files that are needed for an update.

Generating database of files that are needed for an upgrade.
E: Unmet dependencies. Try using -f.
ERROR: FATAL: Something is wrong with the apt system.

2)Then I run and I get:

kwstas@debian:~$ su -c 'apt-get -f install'
Password: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  brasero brasero-cdrkit brasero-common dvdauthor freepats genisoimage
  growisofs libexempi3 libfftw3-double3 libfluidsynth1 libgme0 libgmime-2.6-0
  libgtkglext1 libiptcdata0 libmediaart-1.0-0 libmimic0 libmjpegutils-2.1-0
  libmms0 libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libmusicbrainz5-1
  libnautilus-extension1a libofa0 libopenal-data libopenal1
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libquvi-scripts libquvi7 libsbc1
  libsoundtouch0 libspandsp2 libsrtp0 libtbb2 libtotem-plparser18
  libtracker-sparql-1.0-0 libunistring0 libvo-aacenc0 libvo-amrwbenc0
  libwildmidi-config libwildmidi1 libzbar0 sound-juicer wodim
Suggested packages:
  vcdimager libdvdcss2 tracker readom cdrkit-doc libfftw3-bin libfftw3-dev
  srtp-utils gstreamer1.0-lame gstreamer1.0-plugins-really-bad
Recommended packages:
  yelp
The following packages will be REMOVED:
  gstreamer1.0-plugins-bad
The following NEW packages will be installed:
  brasero-cdrkit dvdauthor freepats genisoimage growisofs libexempi3
  libfftw3-double3 libfluidsynth1 libgme0 libgmime-2.6-0 libgtkglext1
  libiptcdata0 libmediaart-1.0-0 libmimic0 libmjpegutils-2.1-0 libmms0
  libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libmusicbrainz5-1
  libnautilus-extension1a libofa0 libopenal-data libopenal1
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libquvi-scripts libquvi7 libsbc1
  libsoundtouch0 libspandsp2 libsrtp0 libtbb2 libtotem-plparser18
  libtracker-sparql-1.0-0 libunistring0 libvo-aacenc0 libvo-amrwbenc0
  libwildmidi-config libwildmidi1 libzbar0 wodim
The following packages will be upgraded:
  brasero brasero-common sound-juicer
3 upgraded, 51 newly installed, 1 to remove and 2 not upgraded.
4 not fully installed or removed.
Need to get 43.2 MB of archives.
After this operation, 55.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

3)The rest is when I reply yes:

Err http://ftp.cc.uoc.gr/mirrors/linux/debian/ jessie/main brasero i386 3.11.4-1.1
  Could not resolve 'ftp.cc.uoc.gr'
Err http://ftp.cc.uoc.gr/mirrors/linux/debian/ jessie/main brasero-common all 3.11.4-1.1
  Could not resolve 'ftp.cc.uoc.gr'
Err http://ftp.cc.uoc.gr/mirrors/linux/debian/ jessie/main libgmime-2.6-0 i386 2.6.20-1+b1
  Could not resolve 'ftp.cc.uoc.gr'
Err http://ftp.cc.uoc.gr/mirrors/linux/debian/ jessie/main libquvi-scripts all 0.4.21-2
  Could not resolve 'ftp.cc.uoc.gr'

.
.
. and it goes until:

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Circular dependency in Ubuntu Release upgrade


The title is the best way I could describe this error.

Basically the packages kbd, console-setup, console-setup-linux, and keyboard-configuration all depend on each other. So I cannot remove, configure, or purge them. When attempting to run dpkg --configure <package name> it returns the error:

dpkg: dependency problems prevent configuration of <package name>:

It goes on to list the specific dependencies. Upon trying to configure those, it eventually ends up back at the original package.

Am I missing something?


Edit: It appears I can configure keyboard-configuration, but it gives me this error:

user@ip:~$ sudo dpkg --configure keyboard-configuration
Setting up keyboard-configuration (1.108ubuntu5) ...
/var/lib/dpkg/info/keyboard-configuration.postinst: 1: /var/lib/dpkg/info/keyboard-configuration.postinst: udpkg: not found
/usr/bin/ckbcomp: Can not find file "symbols/en" in any known directory
dpkg: error processing package keyboard-configuration (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 keyboard-configuration

Creating objects containing collections of themselves


I’m creating a simple data structure using PL/SQL to help me work with some rows in tables which have dependencies upon each other.

In short, I’d like to be able to create a graph using any combination of Objects/Types/Tables. Each ITEM has a 4 composite keys, and references any amount of other ITEM’s.

The problem is that attempting to create a nested table to contain the dependencies results in a circular reference of sorts, which PL/SQL cannot handle, giving me errors such as the following:

Error: ORA-02303: cannot drop or replace a type with type or table dependents

Error: ORA-06545: PL/SQL: compilation error – compilation aborted
ORA-06550: line 0, column 0:
PLS-00565: DEPENDENCIES must be completed as a potential REF target (object type)

What I’d really like to have is something as simple as the following:

CREATE OR REPLACE
TYPE ITEM AS OBJECT (
  first  VARCHAR2(10),
  second VARCHAR2(10),
  third  VARCHAR2(10),
  fourth VARCHAR2(10),
  deps   DEPENDENCIES
  -- Functions & Procedures omitted
)

CREATE OR REPLACE
TYPE DEPENDENCIES AS TABLE OF ITEM

Is there a way I can satisfy Oracle, or work around this problem?

Decompose table into third normal form


Tables X and Y are given as below :

X (A, B, D, E, F, G, H, J) with A and B as primary key
Y (K, L, M, N, O, P, Q, R) with K and L as primary key

Now we need to decompose these tables into tables in the third normal form using the functional dependencies specified below:

  1. A -> G, H
  2. B -> D, E, F
  3. E -> F
  4. H -> G
  5. L -> N, O, P, Q
  6. N -> Q

I need to specify primary keys and foreign keys also. Please help to solve this problem.

I am newbie to normalization. So please help to solve this problem.If I normalize to 2NF I loose some relations which doesn’t suit to 3NF. So I am confused. Any help will be appreciated. Because to convert to 3NF I need to go through 2NF too.

I had changed it to 3NF. Please help in finding if am right in doing it

R1 (E, F)
R2 (H, G)
R3 (A, B, L)
R4 (A, H)
R5 (B, D, E)

R6 (N, Q)
R7 (K, L, M, R)
R8 (L, N, O, P)

Gpgpu-sim dependencies in centOS


I try to install gpgpu-sim in my CentOS 6, there are some dependencies need to be installed before I can compile gpgpu-sim successfully. the dependencies are as follows:

  1. GPGPU-Sim dependencies:

    • gcc
    • g++
    • make
    • makedepend
    • xutils
    • bison
    • flex
    • zlib
    • CUDA Toolkit
  2. GPGPU-Sim documentation dependencies:

    • doxygen
    • graphvi
  3. AerialVision dependencies:

    • python-pmw
    • python-ply
    • python-numpy
    • libpng12-dev
    • python-matplotlib

I know how to install this dependencies in Ubuntu, the command line are as follows:

sudo apt-get install build-essential xutils-dev bison zlib1g-dev flex  libglu1-mesa-dev
sudo apt-get install doxygen graphviz
sudo apt-get install python-pmw python-ply python-numpy libpng12-dev python-matplotlib
sudo apt-get install libxi-dev libxmu-dev freeglut3-dev

I have installed and run gpgpu-sim in ubuntu 14.04, now I need to installed it on centOS.

I have tried some solution like this:
yum list bison flex
I can get the prompt that bison.x86_64 and flex.x86_64 has installed.

yum search libxi-dev libxmu-dev

I can found matches and installed them.

When I tried to search other dependencies:

yum search build-essential
yum search zlib1g-dev
yum search xutils-dev
yum search libglu1-mesa-dev
yum search python-pmw
yum search python-ply
yum search python-numpy
yum search python-matplotlib
yum search libpng12-dev
yum search freeglut3-dev

the search results are:

warning: no matches found for :<depencency name>

there is different software manager in centOS with ubuntu, who can tell me how to installed these dependencies correctly?

Why does ./configure give me unmet packages, that do not exist?


I’m trying to compile Caribou 0.4.18.1 on Xubuntu 14.04.

In the INSTALL document it says, that I should run ./configure && make && make install.

But the ./configure step ended with:

checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/dist-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/dist-packages
checking for CARIBOU... no
configure: error: Package requirements (
  pygobject-3.0 >= 2.90.3,
  gtk+-3.0      >= 3.0.0,
  clutter-1.0   >= 1.5.11,
  gdk-3.0       >= 3.0.0,
  x11,
  atspi-2
  ) were not met:

No package 'pygobject-3.0' found
No package 'gtk+-3.0' found
No package 'clutter-1.0' found
No package 'gdk-3.0' found
No package 'atspi-2' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CARIBOU_CFLAGS
and CARIBOU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Trying to install any of these packages fails, because they’re not in the package index.

I’ve seen this with some other programs I wanted to compile, so it seems to be a problem with my machine.

Could someone explain to me, what the error is actually saying and what I can do against it?

Breaking dependencies on remote APIs


The system I’m working on has a core web application where the bulk of the work is done. However, it relies on another server to handle transactional finance data. It connects to the server using a REST API. I’m trying to work only on the core web application but I keep hitting pages and function calls that rely on the REST API.

For getting up and running, I was told that the best option is to connect to the VPN and to point the API client to the shared REST API server.

While that’s a reasonable solution for a quick bug fix or QA, I feel that it isn’t very good for the application in general. This massive dependency makes it hard to test and develop but I don’t know how to break it.

What are my options?

Should I be mocking out all the API client calls? Should I be using mocks and patches only when I’m fixing something? Or should I just suck it up and use the VPN and shared REST API server?

Do I need Bower for front end dependencies when I am already using composer?


I use composer for PHP dependencies. I was under the impression that for front end dependencies I should use Bower. So, I installed Bower and loaded my FE dependencies (Bootstrap, jQuery) using that. I then manually symlink to the libraries as follows:

mypc:/var/www/myproject/public/js$ ls -l
total 8
lrwxrwxrwx 1 tom tom   67 Dec 23 07:29 bootstrap.min.js -> /var/www/myproject/bower_components/bootstrap/dist/js/bootstrap.min.js
lrwxrwxrwx 1 tom tom   58 Dec 23 07:29 jquery.min.js -> /var/www/myproject/bower_components/jquery/dist/jquery.min.js

However, I notice that these are stored within a directory /bower_components just as composer dependencies are stored in /vendor. So now I have /bower_components and /vendor as well as /node_modules (for grunt and grunt plugins). So as all Bower does it bring down the repositories, upon which I need to link to them – can I not just use composer for front end libraries too?

"components/jquery": "dev-master"
"components/bootstrap": "dev-master"

.. then create symlinks to the files (e.g. .js .css) in my public/* directories? Is there any reason whhy Bower is still better for managing FE dependencies? Thanks

Question and Answer is proudly powered by WordPress.
Theme "The Fundamentals of Graphic Design" by Arjuna
Icons by FamFamFam